CVE-2016-7943

NameCVE-2016-7943
DescriptionThe XListFonts function in X.org libX11 before 1.6.4 might allow remote X servers to gain privileges via vectors involving length fields, which trigger out-of-bounds write operations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-684-1
NVD severityhigh
Debian Bugs840439

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libx11 (PTS)jessie2:1.6.2-3+deb8u1fixed
jessie (security)2:1.6.2-3+deb8u2fixed
stretch2:1.6.4-3+deb9u1fixed
buster2:1.6.7-1fixed
bullseye, sid2:1.6.9-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libx11source(unstable)2:1.6.4-1low840439
libx11sourcejessie2:1.6.2-3+deb8u1
libx11sourcewheezy2:1.5.0-1+deb7u3DLA-684-1

Notes

https://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=8c29f1607a31dac0911e45a0dd3d74173822b3c9

Search for package or bug name: Reporting problems