Information on source package libx11

Available versions

ReleaseVersion
stretch2:1.6.4-3+deb9u1
stretch (security)2:1.6.4-3+deb9u3
buster2:1.6.7-1+deb10u1
bullseye2:1.6.12-1
sid2:1.6.12-1

Open issues

BugstretchbusterbullseyesidDescription
CVE-2020-14363fixedfixedvulnerablevulnerableAn integer overflow vulnerability leading to a double-free was found i ...

Resolved issues

BugDescription
TEMP-0000000-02F7ABfile descriptor leak when a Compose file uses the "include" directive
CVE-2020-14344An integer overflow leading to a heap-buffer overflow was found in The ...
CVE-2018-14600An issue was discovered in libX11 through 1.6.5. The function XListExt ...
CVE-2018-14599An issue was discovered in libX11 through 1.6.5. The function XListExt ...
CVE-2018-14598An issue was discovered in XListExtensions in ListExt.c in libX11 thro ...
CVE-2016-7943The XListFonts function in X.org libX11 before 1.6.4 might allow remot ...
CVE-2016-7942The XGetImage function in X.org libX11 before 1.6.4 might allow remote ...
CVE-2013-7439Multiple off-by-one errors in the (1) MakeBigReq and (2) SetReqLen mac ...
CVE-2013-2004The (1) GetDatabase and (2) _XimParseStringFile functions in X.org lib ...
CVE-2013-1997Multiple buffer overflows in X.org libX11 1.5.99.901 (1.6 RC1) and ear ...
CVE-2013-1981Multiple integer overflows in X.org libX11 1.5.99.901 (1.6 RC1) and ea ...
CVE-2007-1667Multiple integer overflows in (1) the XGetPixel function in ImUtil.c i ...
CVE-2006-5397The Xinput module (modules/im/ximcp/imLcIm.c) in X.Org libX11 1.0.2 an ...
CVE-2006-4447X.Org and XFree86, including libX11, xdm, xf86dga, xinit, xload, xtran ...

Security announcements

DSA / DLADescription
DLA-2361-1libx11 - security update
DLA-2312-1libx11 - security update
DLA-1482-1libx11 - security update
DLA-684-2libx11 - regression update
DLA-684-1libx11 - security update
DLA-199-1libx11 - security update
DSA-3224-1libx11 - security update
DSA-2693-1libx11 - several

Search for package or bug name: Reporting problems