CVE-2016-7946

NameCVE-2016-7946
DescriptionX.org libXi before 1.7.7 allows remote X servers to cause a denial of service (infinite loop) via vectors involving length fields.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-685-1
NVD severitymedium (attack range: remote)
Debian Bugs840440

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxi (PTS)jessie2:1.7.4-1+deb8u1fixed
buster, sid, stretch2:1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxisource(unstable)2:1.7.8-1low840440
libxisourcejessie2:1.7.4-1+deb8u1medium
libxisourcewheezy2:1.6.1-1+deb7u2mediumDLA-685-1

Notes

https://cgit.freedesktop.org/xorg/lib/libXi/commit/?id=19a9cd607de73947fcfb104682f203ffe4e1f4e5
Regression: https://bugs.freedesktop.org/98204

Search for package or bug name: Reporting problems