CVE-2016-7947

NameCVE-2016-7947
DescriptionMultiple integer overflows in X.org libXrandr before 1.5.1 allow remote X servers to trigger out-of-bounds write operations via a crafted response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-660-1
NVD severityhigh (attack range: remote)
Debian Bugs840441

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxrandr (PTS)wheezy2:1.3.2-2+deb7u1vulnerable
wheezy (security)2:1.3.2-2+deb7u2fixed
jessie2:1.4.2-1vulnerable
buster, sid, stretch2:1.5.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxrandrsource(unstable)2:1.5.1-1low840441
libxrandrsourcewheezy2:1.3.2-2+deb7u2highDLA-660-1

Notes

[jessie] - libxrandr <no-dsa> (Minor issue, will be fixed in a point release)
https://cgit.freedesktop.org/xorg/lib/libXrandr/commit/?id=a0df3e1c7728205e5c7650b2e6dce684139254a6

Search for package or bug name: Reporting problems