CVE-2016-7951

NameCVE-2016-7951
DescriptionMultiple integer overflows in X.org libXtst before 1.2.3 allow remote X servers to trigger out-of-bounds memory access operations by leveraging the lack of range checks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-686-1
NVD severityhigh (attack range: remote)
Debian Bugs840444

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxtst (PTS)jessie2:1.2.2-1+deb8u1fixed
buster, sid, stretch2:1.2.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxtstsource(unstable)2:1.2.3-1low840444
libxtstsourcejessie2:1.2.2-1+deb8u1high
libxtstsourcewheezy2:1.2.1-1+deb7u2highDLA-686-1

Notes

https://cgit.freedesktop.org/xorg/lib/libXtst/commit/?id=9556ad67af3129ec4a7a4f4b54a0d59701beeae3

Search for package or bug name: Reporting problems