CVE-2016-7970

NameCVE-2016-7970
DescriptionBuffer overflow in the calc_coeff function in libass/ass_blur.c in libass before 0.13.4 allows remote attackers to cause a denial of service via unspecified vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libass (PTS)jessie0.10.2-3fixed
stretch1:0.13.4-2fixed
buster, sid1:0.14.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libasssource(unstable)0.13.4-1medium
libasssourcejessie(not affected)
libasssourcewheezy(not affected)

Notes

[jessie] - libass <not-affected> (Vulnerable code introduced later)
[wheezy] - libass <not-affected> (Vulnerable code first introduced in July 2015)
Fixed by: https://github.com/libass/libass/pull/240/commits/08e754612019ed84d1db0d1fc4f5798248decd75
Vulnerable function calc_coeff introduced in: https://github.com/libass/libass/commit/d787615845d78d8f8e6d1a4ffc3dc3eecd8a92f6 (0.13.0)

Search for package or bug name: Reporting problems