CVE-2016-9011

NameCVE-2016-9011
DescriptionThe wmf_malloc function in api.c in libwmf 0.2.8.4 allows remote attackers to cause a denial of service (application crash) via a crafted wmf file, which triggers a memory allocation failure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-694-1
NVD severitymedium (attack range: remote)
Debian Bugs842090

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwmf (PTS)wheezy0.2.8.4-10.3+deb7u1vulnerable
wheezy (security)0.2.8.4-10.3+deb7u2fixed
jessie0.2.8.4-10.3+deb8u2fixed
jessie (security)0.2.8.4-10.3+deb8u1vulnerable
stretch0.2.8.4-10.6fixed
buster0.2.8.4-11fixed
sid0.2.8.4-12fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwmfsource(unstable)0.2.8.4-10.6medium842090
libwmfsourcejessie0.2.8.4-10.3+deb8u2medium
libwmfsourcewheezy0.2.8.4-10.3+deb7u2mediumDLA-694-1

Notes

http://www.openwall.com/lists/oss-security/2016/10/18/9
https://blogs.gentoo.org/ago/2016/10/18/libwmf-memory-allocation-failure-in-wmf_malloc-api-c
Reproducer: https://github.com/asarubbo/poc/blob/master/00015-libwmf-memalloc-wmf_malloc
Proposed patch: https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=842090;filename=libwmf-0.2.8.4-CVE-2016-9011-debian.patch;msg=10

Search for package or bug name: Reporting problems