CVE-2016-9037

NameCVE-2016-9037
DescriptionAn exploitable out-of-bounds array access vulnerability exists in the xrow_header_decode function of Tarantool 1.7.2.0-g8e92715. A specially crafted packet can cause the function to access an element outside the bounds of a global array that is used to determine the type of the specified key's value. This can lead to an out of bounds read within the context of the server. An attacker who exploits this vulnerability can cause a denial of service vulnerability on the server.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tarantool (PTS)jessie1.5.2.20.g5f5d924-2fixed
stretch1.7.2.385.g952d79e-1fixed
bullseye, sid, buster1.9.1.26.g63eb81e3c-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tarantoolsource(unstable)1.7.2.385.g952d79e-1high
tarantoolsourcejessie(not affected)
tarantoolsourcewheezy(not affected)

Notes

[jessie] - tarantool <not-affected> (Vulnerable code not present)
[wheezy] - tarantool <not-affected> (Not vulnerable)
https://github.com/tarantool/tarantool/issues/1992
http://www.talosintelligence.com/reports/TALOS-2016-0255/

Search for package or bug name: Reporting problems