CVE-2016-9480

NameCVE-2016-9480
Descriptionlibdwarf 2016-10-21 allows context-dependent attackers to obtain sensitive information or cause a denial of service by using the "malformed dwarf file" approach, related to a "Heap Buffer Over-read" issue affecting the dwarf_util.c component, aka DW201611-006.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dwarfutils (PTS)jessie20120410-2+deb8u1vulnerable
stretch20161124-1+deb9u1fixed
buster, sid20180809-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dwarfutilssource(unstable)20161124-1medium

Notes

[jessie] - dwarfutils <no-dsa> (Minor issue)
[wheezy] - dwarfutils <no-dsa> (Minor issue)
https://www.prevanders.net/dwarfbug.html#DW201611-006
https://sourceforge.net/p/libdwarf/bugs/5/
https://sourceforge.net/p/libdwarf/code/ci/5dd64de047cd5ec479fb11fe7ff2692fd819e5e5/
The code has substantially changed in libdwarf/dwarf_util.c from older
versions, but there seem to be still back then an unchecked dereference
of val_ptr.

Search for package or bug name: Reporting problems