Information on source package dwarfutils

Available versions

ReleaseVersion
jessie20120410-2+deb8u1
stretch20161124-1+deb9u1
buster20180809-1
sid20180809-1

Open issues

BugjessiestretchbustersidDescription
CVE-2017-9998vulnerable (no DSA)fixedfixedfixedThe _dwarf_decode_s_leb128_chk function in dwarf_leb.c in libdwarf ...
CVE-2017-9055vulnerable (no DSA)fixedfixedfixedAn issue, also known as DW201703-001, was discovered in libdwarf ...
CVE-2017-9054vulnerable (no DSA)fixedfixedfixedAn issue, also known as DW201703-002, was discovered in libdwarf ...
CVE-2017-9053vulnerable (no DSA)fixedfixedfixedAn issue, also known as DW201703-005, was discovered in libdwarf ...
CVE-2017-9052vulnerable (no DSA)fixedfixedfixedAn issue, also known as DW201703-006, was discovered in libdwarf ...
CVE-2016-9558vulnerable (no DSA)fixedfixedfixed(1) libdwarf/dwarf_leb.c and (2) dwarfdump/print_frames.c in libdwarf ...
CVE-2016-9480vulnerable (no DSA)fixedfixedfixedlibdwarf 2016-10-21 allows context-dependent attackers to obtain ...
CVE-2016-9276vulnerable (no DSA)fixedfixedfixedThe dwarf_get_aranges_list function in dwarf_arrange.c in Libdwarf ...
CVE-2016-8681vulnerable (no DSA)fixedfixedfixedThe _dwarf_get_abbrev_for_code function in dwarf_util.c in libdwarf ...
CVE-2016-8680vulnerable (no DSA)fixedfixedfixedThe _dwarf_get_abbrev_for_code function in dwarf_util.c in libdwarf ...
CVE-2016-8679vulnerable (no DSA)fixedfixedfixedThe _dwarf_get_size_of_val function in libdwarf/dwarf_util.c in ...
CVE-2016-7511vulnerable (no DSA)fixedfixedfixedInteger overflow in the dwarf_die_deliv.c in libdwarf 20160613 allows ...
CVE-2016-7510vulnerable (no DSA)fixedfixedfixedThe read_line_table_program function in ...
CVE-2016-5044vulnerable (no DSA)fixedfixedfixedThe WRITE_UNALIGNED function in dwarf_elf_access.c in libdwarf before ...
CVE-2016-5043vulnerable (no DSA)fixedfixedfixedThe dwarf_dealloc function in libdwarf before 20160923 allows remote ...
CVE-2016-5041vulnerable (no DSA)fixedfixedfixeddwarf_macro5.c in libdwarf before 20160923 allows remote attackers to ...
CVE-2016-5040vulnerable (no DSA)fixedfixedfixedlibdwarf before 20160923 allows remote attackers to cause a denial of ...
CVE-2016-5037vulnerable (no DSA)fixedfixedfixedThe _dwarf_load_section function in libdwarf before 20160923 allows ...
CVE-2016-5035vulnerable (no DSA)fixedfixedfixedThe _dwarf_read_line_table_header function in ...
CVE-2016-5033vulnerable (no DSA)fixedfixedfixedThe print_exprloc_content function in libdwarf before 20160923 allows ...
CVE-2016-5032vulnerable (no DSA)fixedfixedfixedThe dwarf_get_xu_hash_entry function in libdwarf before 20160923 ...
CVE-2016-5031vulnerable (no DSA)fixedfixedfixedThe print_frame_inst_bytes function in libdwarf before 20160923 allows ...
CVE-2016-5030vulnerable (no DSA)fixedfixedfixedThe _dwarf_calculate_info_section_end_ptr function in libdwarf before ...
CVE-2016-5029vulnerable (no DSA)fixedfixedfixedThe create_fullest_file_path function in libdwarf before 20160923 ...
CVE-2016-5028vulnerable (no DSA)fixedfixedfixedThe print_frame_inst_bytes function in libdwarf before 20160923 allows ...
CVE-2016-5027vulnerable (no DSA)fixedfixedfixeddwarf_form.c in libdwarf 20160115 allows remote attackers to cause a ...

Resolved issues

BugDescription
CVE-2016-9275Heap-based buffer overflow in the _dwarf_skim_forms function in ...
CVE-2016-7410The _dwarf_read_loc_section function in dwarf_loc.c in libdwarf ...
CVE-2016-5042The dwarf_get_aranges_list function in libdwarf before 20160923 allows ...
CVE-2016-5039The get_attr_value function in libdwarf before 20160923 allows remote ...
CVE-2016-5038The dwarf_get_macro_startend_file function in dwarf_macro5.c in ...
CVE-2016-5036The dump_block function in print_sections.c in libdwarf before ...
CVE-2016-5034dwarf_elf_access.c in libdwarf before 20160923 allows remote attackers ...
CVE-2016-2091The dwarf_read_cie_fde_prefix function in dwarf_frame2.c in libdwarf ...
CVE-2016-2050The get_abbrev_array_info function in libdwarf-20151114 allows remote ...
CVE-2015-8750libdwarf 20151114 and earlier allows remote attackers to cause a ...
CVE-2015-8538dwarf_leb.c in libdwarf allows attackers to cause a denial of service ...
CVE-2014-9482Use-after-free vulnerability in dwarfdump in libdwarf 20130126 through ...

Security announcements

DSA / DLADescription
DLA-669-1dwarfutils - security update
DLA-635-1dwarfutils - security update
DLA-388-1dwarfutils - security update

Search for package or bug name: Reporting problems