CVE-2016-9601

NameCVE-2016-9601
Descriptionghostscript before version 9.21 is vulnerable to a heap based buffer overflow that was found in the ghostscript jbig2_decode_gray_scale_image function which is used to decode halftone segments in a JBIG2 image. A document (PostScript or PDF) with an embedded, specially crafted, jbig2 image could trigger a segmentation fault in ghostscript.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-874-1, DSA-3817-1
NVD severitymedium (attack range: remote)
Debian Bugs850497

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jbig2dec (PTS)jessie (security), jessie0.13-4~deb8u2fixed
stretch0.13-4.1fixed
buster, sid0.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jbig2decsource(unstable)0.13-4medium850497
jbig2decsourcejessie0.13-4~deb8u1mediumDSA-3817-1
jbig2decsourcewheezy0.13-4~deb7u1mediumDLA-874-1

Notes

https://bugs.ghostscript.com/show_bug.cgi?id=697457
Patch: http://git.ghostscript.com/?p=jbig2dec.git;a=commitdiff;h=e698d5c11d27212aa1098bc5b1673a3378563092

Search for package or bug name: Reporting problems