CVE-2016-9809

NameCVE-2016-9809
DescriptionOff-by-one error in the gst_h264_parse_set_caps function in GStreamer before 1.10.2 allows remote attackers to have unspecified impact via a crafted file, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-736-1, DSA-3818-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad0.10 (PTS)wheezy0.10.23-7.1+deb7u2vulnerable
wheezy (security)0.10.23-7.1+deb7u5fixed
jessie (security), jessie0.10.23-7.4+deb8u2vulnerable
gst-plugins-bad1.0 (PTS)jessie (security), jessie1.4.4-2.1+deb8u2fixed
stretch1.10.4-1fixed
buster1.12.3-2fixed
sid1.12.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(unfixed)medium
gst-plugins-bad0.10sourcewheezy0.10.23-7.1+deb7u4mediumDLA-736-1
gst-plugins-bad1.0source(unstable)1.10.2-1medium
gst-plugins-bad1.0sourcejessie1.4.4-2.1+deb8u2mediumDSA-3818-1

Notes

[jessie] - gst-plugins-bad0.10 <no-dsa> (Minor issue, can be fixed via point release)
https://bugzilla.gnome.org/show_bug.cgi?id=774896

Search for package or bug name: Reporting problems