CVE-2016-9812

NameCVE-2016-9812
DescriptionThe gst_mpegts_section_new function in the mpegts decoder in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (out-of-bounds read) via a too small section.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3818-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad0.10 (PTS)wheezy0.10.23-7.1+deb7u2fixed
wheezy (security)0.10.23-7.1+deb7u5fixed
jessie (security), jessie0.10.23-7.4+deb8u2fixed
gst-plugins-bad1.0 (PTS)jessie (security), jessie1.4.4-2.1+deb8u2fixed
stretch1.10.4-1fixed
buster1.12.2-1fixed
sid1.12.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(not affected)
gst-plugins-bad1.0source(unstable)1.10.2-1low
gst-plugins-bad1.0sourcejessie1.4.4-2.1+deb8u2mediumDSA-3818-1

Notes

- gst-plugins-bad0.10 <not-affected> (Vulnerable code introduced in 1.1.1 of 1.0 series)
https://bugzilla.gnome.org/show_bug.cgi?id=775048

Search for package or bug name: Reporting problems