CVE-2016-9813

NameCVE-2016-9813
DescriptionThe _parse_pat function in the mpegts parser in GStreamer before 1.10.2 allows remote attackers to cause a denial of service (NULL pointer dereference and crash) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-3818-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gst-plugins-bad1.0 (PTS)buster1.14.4-1+deb10u2fixed
buster (security)1.14.4-1+deb10u5fixed
bullseye (security), bullseye1.18.4-3+deb11u4fixed
bookworm, bookworm (security)1.22.0-4+deb12u5fixed
trixie1.24.3-1fixed
sid1.24.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gst-plugins-bad0.10source(unstable)(not affected)
gst-plugins-bad1.0sourcejessie1.4.4-2.1+deb8u2DSA-3818-1
gst-plugins-bad1.0source(unstable)1.10.2-1low

Notes

- gst-plugins-bad0.10 <not-affected> (Vulnerable code introduced in 1.1.1 of 1.0 series)
https://bugzilla.gnome.org/show_bug.cgi?id=775120

Search for package or bug name: Reporting problems