CVE-2016-9842

NameCVE-2016-9842
DescriptionThe inflateMark function in inflate.c in zlib 1.2.8 might allow context-dependent attackers to have unspecified impact via vectors involving left shifts of negative integers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1725-1
NVD severitymedium (attack range: remote)
Debian Bugs847274, 924509

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rsync (PTS)jessie3.1.1-3+deb8u1vulnerable
jessie (security)3.1.1-3+deb8u2fixed
stretch3.1.2-1+deb9u2fixed
stretch (security)3.1.2-1+deb9u1vulnerable
bullseye, sid, buster3.1.3-6fixed
zlib (PTS)jessie1:1.2.8.dfsg-2vulnerable
stretch1:1.2.8.dfsg-5fixed
bullseye, sid, buster1:1.2.11.dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rsyncsource(unstable)3.1.3-6medium924509
rsyncsourcejessie3.1.1-3+deb8u2mediumDLA-1725-1
rsyncsourcestretch3.1.2-1+deb9u2medium
zlibsource(unstable)1:1.2.8.dfsg-3medium847274

Notes

[jessie] - zlib <no-dsa> (Minor issue)
[wheezy] - zlib <no-dsa> (Minor issue)
https://github.com/madler/zlib/commit/e54e1299404101a5a9d0cf5e45512b543967f958
Report: https://wiki.mozilla.org/images/0/09/Zlib-report.pdf

Search for package or bug name: Reporting problems