CVE-2016-9888

NameCVE-2016-9888
DescriptionAn error within the "tar_directory_for_file()" function (gsf-infile-tar.c) in GNOME Structured File Library before 1.14.41 can be exploited to trigger a Null pointer dereference and subsequently cause a crash via a crafted TAR file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-740-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgsf (PTS)jessie1.14.30-2vulnerable
stretch1.14.41-1fixed
buster1.14.45-1fixed
bullseye, sid1.14.46-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgsfsource(unstable)1.14.41-1medium
libgsfsourcewheezy1.14.21-2.1+deb7u1mediumDLA-740-1

Notes

[jessie] - libgsf <no-dsa> (Minor issue)
Fixed by: https://github.com/GNOME/libgsf/commit/95a8351a75758cf10b3bf6abae0b6b461f90d9e5

Search for package or bug name: Reporting problems