CVE-2016-9910

NameCVE-2016-9910
DescriptionThe serializer in html5lib before 0.99999999 might allow remote attackers to conduct cross-site scripting (XSS) attacks by leveraging mishandling of special characters in attribute values, a different vulnerability than CVE-2016-9909.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
html5lib (PTS)jessie0.999-3vulnerable
stretch0.999999999-1fixed
bullseye, sid, buster1.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
html5libsource(unstable)0.999999999-1medium

Notes

[jessie] - html5lib <no-dsa> (Minor issue)
[wheezy] - html5lib <no-dsa> (Minor issue)
Fixed by: https://github.com/html5lib/html5lib-python/commit/9b8d8eb5afbc066b7fac9390f5ec75e5e8a7cab7
https://www.sourceclear.com/registry/security/cross-site-scripting-xss-/python/sid-3068
http://www.openwall.com/lists/oss-security/2016/12/06/5

Search for package or bug name: Reporting problems