CVE-2016-9941

NameCVE-2016-9941
DescriptionHeap-based buffer overflow in rfbproto.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message containing a subrectangle outside of the client drawing area.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-777-1, DSA-3753-1
NVD severityhigh (attack range: remote)
Debian Bugs850007

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)wheezy0.9.9+dfsg-1+deb7u1vulnerable
wheezy (security)0.9.9+dfsg-1+deb7u2fixed
jessie (security), jessie0.9.9+dfsg2-6.1+deb8u2fixed
stretch, sid0.9.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.11+dfsg-1high850007
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u2highDSA-3753-1
libvncserversourcewheezy0.9.9+dfsg-1+deb7u2highDLA-777-1

Notes

https://github.com/LibVNC/libvncserver/pull/137
https://github.com/LibVNC/libvncserver/pull/137/commits/5418e8007c248bf9668d22a8c1fa9528149b69f2

Search for package or bug name: Reporting problems