CVE-2016-9942

NameCVE-2016-9942
DescriptionHeap-based buffer overflow in ultra.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message with the Ultra type tile, such that the LZO payload decompressed length exceeds what is specified by the tile dimensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-777-1, DSA-3753-1
NVD severityhigh (attack range: remote)
Debian Bugs850008

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libvncserver (PTS)wheezy0.9.9+dfsg-1+deb7u1vulnerable
wheezy (security)0.9.9+dfsg-1+deb7u2fixed
jessie (security), jessie0.9.9+dfsg2-6.1+deb8u2fixed
stretch, sid0.9.11+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libvncserversource(unstable)0.9.11+dfsg-1high850008
libvncserversourcejessie0.9.9+dfsg2-6.1+deb8u2highDSA-3753-1
libvncserversourcewheezy0.9.9+dfsg-1+deb7u2highDLA-777-1

Notes

https://github.com/LibVNC/libvncserver/pull/137
https://github.com/LibVNC/libvncserver/pull/137/commits/5fff4353f66427b467eb29e5fdc1da4f2be028bb

Search for package or bug name: Reporting problems