CVE-2017-0378

NameCVE-2017-0378
DescriptionXSS exists in the login_form function in views/helpers.php in Phamm before 0.6.7, exploitable via the PATH_INFO to main.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs868988

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phamm (PTS)wheezy0.5.18-3.1vulnerable
jessie0.6.2-1.2vulnerable
buster, sid, stretch0.6.5-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phammsource(unstable)(unfixed)medium868988

Notes

[stretch] - phamm <no-dsa> (Minor issue)
[jessie] - phamm <no-dsa> (Minor issue)
https://github.com/lota/phamm/issues/21
https://github.com/lota/phamm/commit/331bdbf0e79632385495fa62e087a6b4cf78857e

Search for package or bug name: Reporting problems