CVE-2017-0379

NameCVE-2017-0379
DescriptionLibgcrypt before 1.8.1 does not properly consider Curve25519 side-channel attacks, which makes it easier for attackers to discover a secret key, related to cipher/ecc.c and mpi/ec.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3959-1
NVD severitymedium (attack range: remote)
Debian Bugs873383

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt11 (PTS)wheezy1.5.0-5+deb7u4fixed
wheezy (security)1.5.0-5+deb7u6fixed
libgcrypt20 (PTS)jessie (security), jessie1.6.3-2+deb8u4fixed
stretch (security), stretch1.7.6-2+deb9u2fixed
buster, sid1.7.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgcrypt11source(unstable)(not affected)
libgcrypt20source(unstable)1.7.9-1medium873383
libgcrypt20sourcejessie(not affected)
libgcrypt20sourcestretch1.7.6-2+deb9u2mediumDSA-3959-1

Notes

[jessie] - libgcrypt20 <not-affected> (Vulnerable code not present, no Curve25519 support)
- libgcrypt11 <not-affected> (Vulnerable code not present, no Curve25519 support)
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commitdiff;h=da780c8183cccc8f533c8ace8211ac2cb2bdee7b
https://eprint.iacr.org/2017/806

Search for package or bug name: Reporting problems