DescriptionAn elevation of privilege vulnerability in libnl could enable a local malicious application to execute arbitrary code within the context of the Wi-Fi service. This issue is rated as Moderate because it first requires compromising a privileged process and is mitigated by current platform configurations. Product: Android. Versions: 5.0.2, 5.1.1, 6.0, 6.0.1, 7.0, 7.1.1. Android ID: A-32342065. NOTE: this issue also exists in the upstream libnl before 3.3.0 library.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-891-1, DLA-892-1
NVD severityhigh (attack range: remote)
Debian Bugs859948

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libnl (PTS)wheezy1.1-7vulnerable
wheezy (security)1.1-7+deb7u1fixed
libnl3 (PTS)wheezy3.2.7-4vulnerable
wheezy (security)3.2.7-4+deb7u1fixed
buster, sid, stretch3.2.27-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Fixed by:
Fix via Android:
Not a security issue by itself, the upstream patch protects against API misuse,
this still requires missing input validation in the application using libnl

Search for package or bug name: Reporting problems