CVE-2017-0900

NameCVE-2017-0900
DescriptionRubyGems version 2.6.12 and earlier is vulnerable to maliciously crafted gem specifications to cause a denial of service attack against RubyGems clients who have issued a `query` command.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1112-1, DLA-1114-1, DSA-3966-1
NVD severitymedium (attack range: remote)
Debian Bugs873802

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby1.9.1 (PTS)wheezy1.9.3.194-8.1+deb7u5vulnerable
wheezy (security)1.9.3.194-8.1+deb7u6fixed
ruby2.1 (PTS)jessie2.1.5-2+deb8u3vulnerable
jessie (security)2.1.5-2+deb8u1vulnerable
ruby2.3 (PTS)buster, sid, stretch (security), stretch2.3.3-1+deb9u1fixed
rubygems (PTS)wheezy1.8.24-1vulnerable
wheezy (security)1.8.24-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby1.9.1source(unstable)(unfixed)medium
ruby1.9.1sourcewheezy1.9.3.194-8.1+deb7u6mediumDLA-1114-1
ruby2.1source(unstable)(unfixed)medium
ruby2.3source(unstable)2.3.3-1+deb9u1medium873802
ruby2.3sourcestretch2.3.3-1+deb9u1mediumDSA-3966-1
rubygemssource(unstable)(unfixed)medium
rubygemssourcewheezy1.8.24-1+deb7u1mediumDLA-1112-1

Notes

https://www.ruby-lang.org/en/news/2017/08/29/multiple-vulnerabilities-in-rubygems/
http://blog.rubygems.org/2017/08/27/2.6.13-released.html
For Ruby 2.3.4: https://bugs.ruby-lang.org/attachments/download/6691/rubygems-2613-ruby23.patch
For Ruby 2.2.7: https://bugs.ruby-lang.org/attachments/download/6690/rubygems-2613-ruby22.patch

Search for package or bug name: Reporting problems