CVE-2017-1000026

NameCVE-2017-1000026
DescriptionChef Software's mixlib-archive versions 0.3.0 and older are vulnerable to a directory traversal attack allowing attackers to overwrite arbitrary files by using ".." in tar archive entries
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3915-1
NVD severitymedium (attack range: remote)
Debian Bugs868572

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-mixlib-archive (PTS)stretch (security), stretch0.2.0-1+deb9u1fixed
buster, sid0.4.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-mixlib-archivesource(unstable)0.4.1-1medium868572
ruby-mixlib-archivesourcestretch0.2.0-1+deb9u1mediumDSA-3915-1

Notes

https://github.com/chef/mixlib-archive/pull/6
https://github.com/chef/mixlib-archive/pull/6/commits/3a874a24aed6ee93fbccf97efe0ecc999bafe87d

Search for package or bug name: Reporting problems