CVE-2017-1000083

NameCVE-2017-1000083
Descriptionbackend/comics/comics-document.c (aka the comic book backend) in GNOME Evince before 3.24.1 allows remote attackers to execute arbitrary commands via a .cbt file that is a TAR archive containing a filename beginning with a "--" command-line option substring, as demonstrated by a --checkpoint-action=exec=bash at the beginning of the filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1031-1, DSA-3911-1, DSA-3916-1
NVD severitymedium (attack range: remote)
Debian Bugs868500

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
atril (PTS)jessie1.8.1+dfsg1-4vulnerable
jessie (security)1.8.1+dfsg1-4+deb8u1fixed
stretch1.16.1-2vulnerable
stretch (security)1.16.1-2+deb9u1fixed
buster, sid1.18.1-1fixed
evince (PTS)wheezy3.4.0-3.1vulnerable
wheezy (security)3.4.0-3.1+deb7u1fixed
jessie (security), jessie3.14.1-2+deb8u2fixed
stretch (security), stretch3.22.1-3+deb9u1fixed
buster, sid3.25.92-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
atrilsource(unstable)1.16.1-2.1medium868500
atrilsourcejessie1.8.1+dfsg1-4+deb8u1mediumDSA-3916-1
atrilsourcestretch1.16.1-2+deb9u1mediumDSA-3916-1
evincesource(unstable)3.22.1-4medium
evincesourcejessie3.14.1-2+deb8u2mediumDSA-3911-1
evincesourcestretch3.22.1-3+deb9u1mediumDSA-3911-1
evincesourcewheezy3.4.0-3.1+deb7u1mediumDLA-1031-1

Notes

https://bugzilla.gnome.org/show_bug.cgi?id=784630

Search for package or bug name: Reporting problems