CVE-2017-1000211

NameCVE-2017-1000211
DescriptionLynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1175-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lynx (PTS)stretch2.8.9dev11-1vulnerable
buster2.8.9rel.1-3fixed
bullseye, sid2.9.0dev.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lynxsource(unstable)2.8.9dev16-1
lynx-cursourcewheezy2.8.8dev.12-2+deb7u2DLA-1175-1
lynx-cursource(unstable)(unfixed)

Notes

[stretch] - lynx <no-dsa> (Minor issue)
[jessie] - lynx-cur <no-dsa> (Minor issue)
https://github.com/ThomasDickey/lynx-snapshots/commit/280a61b300a1614f6037efc0902ff7ecf17146e9

Search for package or bug name: Reporting problems