CVE-2017-1000229

NameCVE-2017-1000229
DescriptionInteger overflow bug in function minitiff_read_info() of optipng 0.7.6 allows an attacker to remotely execute code or cause denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1184-1, DSA-4058-1
NVD severitymedium (attack range: remote)
Debian Bugs882032

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optipng (PTS)jessie (security), jessie0.7.5-1+deb8u2fixed
stretch (security), stretch0.7.6-1+deb9u1fixed
buster, sid0.7.6-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optipngsource(unstable)0.7.6-1.1medium882032
optipngsourcejessie0.7.5-1+deb8u2mediumDSA-4058-1
optipngsourcestretch0.7.6-1+deb9u1mediumDSA-4058-1
optipngsourcewheezy0.6.4-1+deb7u3mediumDLA-1184-1

Notes

https://sourceforge.net/p/optipng/bugs/65/
Proposed patch: https://sourceforge.net/p/optipng/bugs/_discuss/thread/2a56b3aa/f6bb/attachment/0001-Prevent-integer-overflow-bug-65-CVE-2017-1000229.patch

Search for package or bug name: Reporting problems