DescriptionSyncthing version 0.14.33 and older is vulnerable to symlink traversal resulting in arbitrary file overwrite
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
syncthing (PTS)stretch0.14.18+dfsg1-2vulnerable
buster, sid1.0.0~ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[stretch] - syncthing <no-dsa> (Minor issue) (v0.14.34)

Search for package or bug name: Reporting problems