CVE-2017-1000420

NameCVE-2017-1000420
DescriptionSyncthing version 0.14.33 and older is vulnerable to symlink traversal resulting in arbitrary file overwrite
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
syncthing (PTS)stretch0.14.18+dfsg1-2vulnerable
buster, sid0.14.46+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
syncthingsource(unstable)0.14.36+ds1-1medium

Notes

[stretch] - syncthing <no-dsa> (Minor issue)
https://github.com/syncthing/syncthing/commit/1f09488a0f1fdca07076b007b9789f23a6df1060 (v0.14.34)
https://github.com/syncthing/syncthing/commit/a0f771c221f6ef18fcc496e736670d85f36b8dec
https://github.com/syncthing/syncthing/issues/4286

Search for package or bug name: Reporting problems