CVE-2017-1000421

NameCVE-2017-1000421
DescriptionGifsicle gifview 1.89 and older is vulnerable to a use-after-free in the read_gif function resulting potential code execution
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1233-1, DSA-4084-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gifsicle (PTS)jessie (security), jessie1.86-1+deb8u1fixed
stretch (security), stretch1.88-3+deb9u1fixed
buster, sid1.91-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gifsiclesource(unstable)1.90-1high
gifsiclesourcejessie1.86-1+deb8u1highDSA-4084-1
gifsiclesourcestretch1.88-3+deb9u1highDSA-4084-1
gifsiclesourcewheezy1.67-1.1~deb7u1highDLA-1233-1

Notes

https://github.com/kohler/gifsicle/issues/114
https://github.com/kohler/gifsicle/commit/81fd7823f6d9c85ab598bc850e40382068361185

Search for package or bug name: Reporting problems