CVE-2017-1000427

NameCVE-2017-1000427
Descriptionmarked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs886451

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-marked (PTS)jessie0.3.2+dfsg-1vulnerable
stretch0.3.6+dfsg-1vulnerable
buster0.3.9+dfsg-1fixed
sid0.5.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-markedsource(unstable)0.3.9+dfsg-1unimportant886451

Notes

https://github.com/chjj/marked/commit/cd2f6f5b7091154c5526e79b5f3bfb4d15995a51
nodejs not covered by security support

Search for package or bug name: Reporting problems