CVE-2017-1000456

NameCVE-2017-1000456
Descriptionfreedesktop.org libpoppler 0.60.1 fails to validate boundaries in TextPool::addWord, leading to overflow in subsequent calculations.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1228-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6vulnerable
wheezy (security)0.18.4-6+deb7u5fixed
jessie0.26.5-2+deb8u1vulnerable
jessie (security)0.26.5-2+deb8u2vulnerable
stretch0.48.0-2vulnerable
stretch (security)0.48.0-2+deb9u1vulnerable
buster, sid0.61.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
popplersource(unstable)0.61.1-2medium
popplersourcewheezy0.18.4-6+deb7u5mediumDLA-1228-1

Notes

https://bugs.freedesktop.org/show_bug.cgi?id=103116
Fixed by: https://cgit.freedesktop.org/poppler/poppler/commit/?id=7ee9dadef37b20bca707a6b1e858e17d191e368b

Search for package or bug name: Reporting problems