CVE-2017-1000458

NameCVE-2017-1000458
DescriptionBro before Bro v2.5.2 is vulnerable to an out of bounds write in the ContentLine analyzer allowing remote attackers to cause a denial of service (crash) and possibly other exploitation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bro (PTS)stretch2.5-1vulnerable
buster2.5.3-1fixed
sid2.5.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
brosource(unstable)2.5.2-1high

Notes

[stretch] - bro <no-dsa> (Minor issue)
https://bro-tracker.atlassian.net/browse/BIT-1856
https://github.com/bro/bro/commit/6c0f101a62489b1c5927b4ed63b0e1d37db40282

Search for package or bug name: Reporting problems