CVE-2017-1002201

NameCVE-2017-1002201
DescriptionIn haml versions prior to version 5.0.0.beta.2, when using user input to perform tasks on the server, characters like < > " ' must be escaped properly. In this case, the ' character was missed. An attacker can manipulate the input to introduce additional attributes, potentially executing code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1986-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-haml (PTS)jessie4.0.5-2vulnerable
jessie (security)4.0.5-2+deb8u1fixed
stretch4.0.7-1vulnerable
buster5.0.4-3fixed
bullseye, sid5.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-hamlsource(unstable)5.0.4-1
ruby-hamlsourcejessie4.0.5-2+deb8u1DLA-1986-1

Notes

[stretch] - ruby-haml <no-dsa> (Minor issue)
https://snyk.io/vuln/SNYK-RUBY-HAML-20362
https://github.com/haml/haml/commit/18576ae6e9bdcb4303fdbe6b3199869d289d67c2

Search for package or bug name: Reporting problems