CVE-2017-10791

NameCVE-2017-10791
DescriptionThere is an Integer overflow in the hash_int function of the libpspp library in GNU PSPP before 0.11.0. For example, a crash was observed within the library code when attempting to convert invalid SPSS data into CSV format. A crafted input will lead to a remote denial of service attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs866890

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pspp (PTS)wheezy0.7.9+git20120620-1.1vulnerable
jessie0.8.4-1vulnerable
stretch0.10.2-1vulnerable
buster, sid1.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
psppsource(unstable)1.0.0-1unimportant866890

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1467004
No security impact as built in Debian

Search for package or bug name: Reporting problems