CVE-2017-10966

NameCVE-2017-10966
DescriptionAn issue was discovered in Irssi before 1.0.4. While updating the internal nick list, Irssi could incorrectly use the GHashTable interface and free the nick while updating it. This would then result in use-after-free conditions on each access of the hash table.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1089-1
NVD severityhigh (attack range: remote)
Debian Bugs867598

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
irssi (PTS)wheezy0.8.15-5vulnerable
wheezy (security)0.8.15-5+deb7u3fixed
jessie (security), jessie0.8.17-1+deb8u4vulnerable
stretch1.0.2-1+deb9u2fixed
stretch (security)1.0.2-1+deb9u1vulnerable
buster, sid1.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
irssisource(unstable)1.0.4-1low867598
irssisourcestretch1.0.2-1+deb9u2high
irssisourcewheezy0.8.15-5+deb7u3highDLA-1089-1

Notes

[jessie] - irssi <no-dsa> (Minor issue)
https://irssi.org/security/irssi_sa_2017_07.txt
https://github.com/irssi/irssi/commit/5e26325317c72a04c1610ad952974e206384d291

Search for package or bug name: Reporting problems