CVE-2017-11170

NameCVE-2017-11170
DescriptionThe ReadTGAImage function in coders\tga.c in ImageMagick 7.0.5-6 has a memory leak vulnerability that can cause memory exhaustion via invalid colors data in the header of a TGA or VST file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1081-1, DSA-3914-1
NVD severitymedium (attack range: remote)
Debian Bugs868184

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u18fixed
jessie8:6.8.9.9-5+deb8u9vulnerable
jessie (security)8:6.8.9.9-5+deb8u11fixed
stretch8:6.9.7.4+dfsg-11+deb9u1fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u3fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-12low868184
imagemagicksourcejessie8:6.8.9.9-5+deb8u10mediumDSA-3914-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u1mediumDSA-3914-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u16mediumDLA-1081-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/472

Search for package or bug name: Reporting problems