CVE-2017-11450

NameCVE-2017-11450
Descriptioncoders/jpeg.c in ImageMagick before 7.0.6-1 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via JPEG data that is too short.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1081-1, DSA-3914-1
NVD severitymedium (attack range: remote)
Debian Bugs867894

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4vulnerable
wheezy (security)8:6.7.7.10-5+deb7u17fixed
jessie8:6.8.9.9-5+deb8u9vulnerable
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.7.4+dfsg-12medium867894
imagemagicksourcejessie8:6.8.9.9-5+deb8u10mediumDSA-3914-1
imagemagicksourcestretch8:6.9.7.4+dfsg-11+deb9u1mediumDSA-3914-1
imagemagicksourcewheezy8:6.7.7.10-5+deb7u16mediumDLA-1081-1

Notes

https://github.com/ImageMagick/ImageMagick/issues/556
https://github.com/ImageMagick/ImageMagick/commit/948356eec65aea91995d4b7cc487d197d2c5f602

Search for package or bug name: Reporting problems