CVE-2017-11636

NameCVE-2017-11636
DescriptionGraphicsMagick 1.3.26 has a heap overflow in the WriteRGBImage() function in coders/rgb.c when processing multiple frames that have non-identical widths.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1045-1, DLA-1401-1, DSA-4321-1
NVD severityhigh (attack range: remote)
Debian Bugs870149

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u4fixed
stretch (security), stretch1.3.30+hg15796-1~deb9u2fixed
buster, sid1.3.31-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.26-4high870149
graphicsmagicksourcejessie1.3.20-3+deb8u3highDLA-1401-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1highDSA-4321-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u8highDLA-1045-1

Notes

http://hg.code.sf.net/p/graphicsmagick/code/rev/39961adf974c

Search for package or bug name: Reporting problems