CVE-2017-11638

NameCVE-2017-11638
DescriptionGraphicsMagick 1.3.26 has a segmentation violation in the WriteMAPImage() function in coders/map.c when processing a non-colormapped image, a different vulnerability than CVE-2017-11642.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1045-1, DLA-1456-1, DSA-4321-1
NVD severitymedium
Debian Bugs870154

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)stretch (security), stretch1.3.30+hg15796-1~deb9u4fixed
buster, buster (security)1.4+really1.3.35-1~deb10u1fixed
bullseye1.4+really1.3.35+hg16348-1fixed
sid1.4+really1.3.35+hg16390-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksourcewheezy1.3.16-1.1+deb7u8DLA-1045-1
graphicsmagicksourcejessie1.3.20-3+deb8u4DLA-1456-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1DSA-4321-1
graphicsmagicksource(unstable)1.3.26-4870154

Notes

http://hg.code.sf.net/p/graphicsmagick/code/rev/29550606d8b9

Search for package or bug name: Reporting problems