CVE-2017-11642

NameCVE-2017-11642
DescriptionGraphicsMagick 1.3.26 has a NULL pointer dereference in the WriteMAPImage() function in coders/map.c when processing a non-colormapped image, a different vulnerability than CVE-2017-11638.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1045-1, DLA-1456-1, DSA-4321-1
NVD severitymedium (attack range: remote)
Debian Bugs870156

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u4fixed
stretch (security), stretch1.3.30+hg15796-1~deb9u2fixed
buster, sid1.3.30+hg15796-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.26-4medium870156
graphicsmagicksourcejessie1.3.20-3+deb8u4mediumDLA-1456-1
graphicsmagicksourcestretch1.3.30+hg15796-1~deb9u1mediumDSA-4321-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u8mediumDLA-1045-1

Notes

http://hg.code.sf.net/p/graphicsmagick/code/rev/29550606d8b9

Search for package or bug name: Reporting problems