CVE-2017-12134

NameCVE-2017-12134
DescriptionThe xen_biovec_phys_mergeable function in drivers/xen/biomerge.c in Xen might allow local OS guest users to corrupt block device data streams and consequently obtain sensitive memory information, cause a denial of service, or gain host OS privileges by leveraging incorrect block IO merge-ability calculation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1099-1, DSA-3981-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.93-1fixed
jessie3.16.43-2+deb8u2vulnerable
jessie (security)3.16.43-2+deb8u5fixed
stretch4.9.30-2+deb9u2vulnerable
stretch (security)4.9.30-2+deb9u5fixed
buster4.12.12-2fixed
sid4.12.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.12.12-1high
linuxsourcejessie3.16.43-2+deb8u5highDSA-3981-1
linuxsourcestretch4.9.30-2+deb9u5highDSA-3981-1
linuxsourcewheezy3.2.93-1highDLA-1099-1

Notes

https://xenbits.xen.org/xsa/advisory-229.html
https://git.kernel.org/linus/462cdace790ac2ed6aad1b19c9c0af0143b6aab0 (v4.13-rc6)

Search for package or bug name: Reporting problems