CVE-2017-12179

NameCVE-2017-12179
Descriptionxorg-x11-server before 1.19.5 was vulnerable to integer overflow in (S)ProcXIBarrierReleasePointer functions allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4000-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)jessie (security), jessie2:1.16.4-1+deb8u2fixed
stretch (security), stretch2:1.19.2-1+deb9u2fixed
buster2:1.19.6-1fixed
sid2:1.20.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.19.5-1high
xorg-serversourcejessie2:1.16.4-1+deb8u2highDSA-4000-1
xorg-serversourcestretch2:1.19.2-1+deb9u2highDSA-4000-1
xorg-serversourcewheezy(not affected)

Notes

[wheezy] - xorg-server <not-affected> (Vulnerable code introduced later)

Search for package or bug name: Reporting problems