CVE-2017-12186

NameCVE-2017-12186
Descriptionxorg-x11-server before 1.19.5 was missing length validation in X-Resource extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4000-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)jessie (security), jessie2:1.16.4-1+deb8u2fixed
stretch2:1.19.2-1+deb9u5fixed
stretch (security)2:1.19.2-1+deb9u4fixed
buster, sid2:1.20.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.19.5-1high
xorg-serversourcejessie2:1.16.4-1+deb8u2highDSA-4000-1
xorg-serversourcestretch2:1.19.2-1+deb9u2highDSA-4000-1
xorg-serversourcewheezy(not affected)

Notes

[wheezy] - xorg-server <not-affected> (Vulnerable code introduced later)
https://cgit.freedesktop.org/xorg/xserver/commit/?id=cad5a1050b7184d828aef9c1dd151c3ab649d37e

Search for package or bug name: Reporting problems