CVE-2017-12194

NameCVE-2017-12194
DescriptionA flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs898503

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice-gtk (PTS)jessie0.25-1vulnerable
jessie (security)0.25-1+deb8u1vulnerable
stretch0.33-3.3+deb9u1vulnerable
buster0.35-2fixed
bullseye, sid0.37-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spice-gtksource(unstable)0.35-1898503
spice-gtksourcewheezy(not affected)

Notes

[stretch] - spice-gtk <no-dsa> (Minor issue)
[jessie] - spice-gtk <no-dsa> (Minor issue)
[wheezy] - spice-gtk <not-affected> (Vulnerable code is not in any binary package, only in the source package)
Proposed patches in: https://bugzilla.redhat.com/show_bug.cgi?id=1240165
Although not present in the binary packages the (de)marshal.py are used to
generate repsecitve code which should be in libspice-common-client.

Search for package or bug name: Reporting problems