DescriptionA flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs898503

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spice-gtk (PTS)bullseye0.39-1fixed
sid, trixie0.42-2.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spice-gtksourcewheezy(not affected)


[stretch] - spice-gtk <no-dsa> (Minor issue)
[jessie] - spice-gtk <no-dsa> (Minor issue)
[wheezy] - spice-gtk <not-affected> (Vulnerable code is not in any binary package, only in the source package)
Proposed patches in:
Although not present in the binary packages the (de) are used to
generate repsecitve code which should be in libspice-common-client.

Search for package or bug name: Reporting problems