CVE-2017-12837

NameCVE-2017-12837
DescriptionHeap-based buffer overflow in the regular expression compiler in PERL before 5.24.3-RC1 and 5.26.x before 5.26.1-RC1 allows remote attackers to cause a denial of service (crash) via a crafted regular expression with the case-insensitive modifier.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3982-1
Debian Bugs875596

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
perl (PTS)wheezy5.14.2-21+deb7u3fixed
wheezy (security)5.14.2-21+deb7u5fixed
jessie5.20.2-3+deb8u8vulnerable
jessie (security)5.20.2-3+deb8u9fixed
stretch5.24.1-3+deb9u1vulnerable
stretch (security)5.24.1-3+deb9u2fixed
buster, sid5.26.0-8fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
perlsource(unstable)5.26.0-8875596
perlsourcejessie5.20.2-3+deb8u9DSA-3982-1
perlsourcestretch5.24.1-3+deb9u2DSA-3982-1
perlsourcewheezy(not affected)

Notes

[wheezy] - perl <not-affected> (Vulnerable code introduced after 5.14.4)
https://rt.perl.org/Public/Bug/Display.html?id=131582 (not yet public)
https://perl5.git.perl.org/perl.git/commitdiff/96c83ed78aeea1a0496dd2b2d935869a822dc8a5
maint-5.26: https://perl5.git.perl.org/perl.git/commitdiff/66288bb3f44c8aa5122e5f40d8cfc0eada8b1695
maint-5.24: https://perl5.git.perl.org/perl.git/commitdiff/f7e5417e7bffba03947b66e4d8622d7c220f2876

Search for package or bug name: Reporting problems