CVE-2017-12932

NameCVE-2017-12932
Descriptionext/standard/var_unserializer.re in PHP 7.0.x through 7.0.22 and 7.1.x through 7.1.8 is prone to a heap use after free while unserializing untrusted data, related to improper use of the hash API for key deletion in a situation with an invalid array size. Exploitation of this issue can have an unspecified impact on the integrity of PHP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.19-1vulnerable
buster, sid7.0.22-3fixed
php7.1 (PTS)buster, sid7.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0source(unstable)7.0.22-1high
php7.1source(unstable)7.1.8-1high

Notes

Fixed in 7.1.8, 7.0.22
PHP Bug: https://bugs.php.net/bug.php?id=74103
https://github.com/php/php-src/commit/1a23ebc1fff59bf480ca92963b36eba5c1b904c4

Search for package or bug name: Reporting problems