CVE-2017-12934

NameCVE-2017-12934
Descriptionext/standard/var_unserializer.re in PHP 7.0.x before 7.0.21 and 7.1.x before 7.1.7 is prone to a heap use after free while unserializing untrusted data, related to the zval_get_type function in Zend/zend_types.h. Exploitation of this issue can have an unspecified impact on the integrity of PHP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4080-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.19-1vulnerable
stretch (security)7.0.27-0+deb9u1fixed
buster, sid7.0.27-1fixed
php7.1 (PTS)buster, sid7.1.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php7.0source(unstable)7.0.22-1medium
php7.0sourcestretch7.0.27-0+deb9u1mediumDSA-4080-1
php7.1source(unstable)7.1.8-1medium

Notes

Fixed in 7.1.7, 7.0.21
PHP Bug: https://bugs.php.net/bug.php?id=74101

Search for package or bug name: Reporting problems