CVE-2017-12958

NameCVE-2017-12958
DescriptionThere is an illegal address access in the function output_hex() in data/data-out.c of the libpspp library in GNU PSPP before 1.0.1 that will lead to remote denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pspp (PTS)jessie0.8.4-1vulnerable
stretch0.10.2-1vulnerable
sid1.0.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
psppsource(unstable)1.0.1-1unimportant

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1482429
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems