CVE-2017-13063

NameCVE-2017-13063
DescriptionGraphicsMagick 1.3.26 has a heap-based buffer overflow vulnerability in the function GetStyleTokens in coders/svg.c:314:12.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1082-1
NVD severitymedium (attack range: remote)
Debian Bugs873130

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u9fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8vulnerable
buster1.3.26-9fixed
sid1.3.26-10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.26-7medium873130
graphicsmagicksourcewheezy1.3.16-1.1+deb7u9mediumDLA-1082-1

Notes

https://sourceforge.net/p/graphicsmagick/bugs/434/
http://hg.code.sf.net/p/graphicsmagick/code/rev/54f48ab2d52a

Search for package or bug name: Reporting problems