CVE-2017-13723

NameCVE-2017-13723
DescriptionIn X.Org Server (aka xserver and xorg-server) before 1.19.4, a local attacker authenticated to the X server could overflow a global buffer, causing crashes of the X server or potentially other problems by injecting large or malformed XKB related atoms and accessing them via xkbcomp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1186-1, DSA-4000-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xorg-server (PTS)jessie (security), jessie2:1.16.4-1+deb8u2fixed
stretch2:1.19.2-1+deb9u5fixed
stretch (security)2:1.19.2-1+deb9u4fixed
buster, bullseye, sid2:1.20.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xorg-serversource(unstable)2:1.19.4-1medium
xorg-serversourcejessie2:1.16.4-1+deb8u2mediumDSA-4000-1
xorg-serversourcestretch2:1.19.2-1+deb9u2mediumDSA-4000-1
xorg-serversourcewheezy2:1.12.4-6+deb7u8mediumDLA-1186-1

Notes

https://cgit.freedesktop.org/xorg/xserver/commit/?id=94f11ca5cf011ef123bd222cabeaef6f424d76ac
This is in libxkbfile in wheezy

Search for package or bug name: Reporting problems